Recalibrate Laptop battery on Mint


New Member
Jun 19, 2023
Reaction score
Hello everyone,
I own a HP EliteBook 745 G3, which I bought used and refurbished a few years ago.
It runs Linux Mint 21.1, Kernel Linux 5.19.0-43-generic.
3 weeks ago, the battery died, and I immediately opened the thing up, to see what the problem was, and one of the three lipos, which make up the battery, was pillowed.

I was extremely lucky, and had 3 lipos laying around with the same voltage. They all happened to be the same capacity (10000mah), but the old ones were 3400mah.
So by switching the old 3400mah ones out for the new 10ah ones, i essentially tripled the capacity of the laptop.

Now my problem is, I dont think the Laptop understood what I did, so it still thinks it runs on the old battery.
How can I force my system to test for the new battery capacity and thus recalculate the new battery runtime?
I really appreciate your help!
Hope you have a good day.

TL;DR: Recalibration of the battery gauge is always good when the batteries are new, and may be the fix if your embedded controller thinks the cells are smaller than they really are.

1) Inspecing how big the laptop thinks the battery is, with TLP
You can install tlp and configure it your your system. Although the defaults for this purpose may suffice, the official documentation may point you in the right direction w.r.t. modules and specific instructions for your distribution (check

Once you have it installed, run sudo tlp-stat -b:
$ sudo tlp-stat -b
Place your right index finger on the fingerprint reader
--- TLP 1.5.0 --------------------------------------------

+++ Battery Care
Plugin: generic
Supported features: none available

+++ Battery Status: BAT1
/sys/class/power_supply/BAT1/manufacturer                   = NVT
/sys/class/power_supply/BAT1/model_name                     = FRANGWA
/sys/class/power_supply/BAT1/cycle_count                    =      7
/sys/class/power_supply/BAT1/charge_full_design             =   whatever [mAh]
/sys/class/power_supply/BAT1/charge_full                    =   whatever [mAh]
/sys/class/power_supply/BAT1/charge_now                     =   whatever [mAh]
/sys/class/power_supply/BAT1/current_now                    =    913 [mA]
/sys/class/power_supply/BAT1/status                         = Charging

/sys/class/power_supply/BAT1/charge_control_start_threshold = (not available)
/sys/class/power_supply/BAT1/charge_control_end_threshold   = (not available)

Charge                                                      =   92.8 [%]
Capacity                                                    =  100.6 [%]
Check that the charge_full_design makes sense with the capacity of your cells. If it doesn't, then you'll probably are in a scenario where the embedded controller thinks its cells are smaller.

Although few and narrow, chances are you can fix it by running a recallibration. First, go to your BIOS / UEFI and check whether or not you have an option to do so. On older laptops (older thinkpads, one Asus I had in 2003) there is a meny for maintenance that has options to recalibrate the battery.

A second (and third) option is with TLP, or manual.

Recalibration With TLP
Check the info of the Battery Care plugin in the above output. If it claims your installation supports recalibration, then run sudo tlp-recalibrate BATx, where BATx is BAT0 or BAT1 depending on the output of the tlp command above.

Manual Recalibration
If, like in my case, the tlp output says something like
Plugin: generic
Supported features: none available
Then you will have to manually drain the battery until the system powers off, and then leave it plugged (and preferably powered off / untouched) until the battery is fully charged.
Last edited:
@gvisoc thanks!
tlp revealed that the laptop thinks the battery ist still at the old capacity, and recalibration is not possible.
I have already tried to discharge the thing fully and then charge it to the max (left in on the charger over night) but it still shows the same result.
My knowledge ends here! Not sure if you, as you seem to be a good tinkerer, would be inclined to search for an alternative embedded controller for your battery. Absolutely ignorant on whether a different module or some kernel options may work.

Members online