• Thread starter Deleted member 101831
  • Start date

How's the performance vis-a-vis X11, Nelson?
Performance is faster and it seems as though it uses a bit less memory.
Cool! As things change in GNU/Linux, so this Boomer must do so, as well.

BTW, re: "mental well-being and coping strategies" thread, I maintain and heve to cope on occassion by placing some on my Ignore list. Two there, so far. Not you, however, friend!

Thanks for the 'heads up' on Wayland.

Probably still a few bugs here and there depending on what software is being used etc.

I may have to give Wayland a try with other Linux distros and see how it works.

I know there's a lot of users who don't care for what Canonical / Ubuntu is doing but I have no problems with them.

I'm willing to give new changes a try and see what they are about because if you don't ever try than you don't / won't ever know.

One thing I know is on my Ubuntu 20.04 desktop Wayland is running great.
My most-frequently-used Ubuntu 20.04 LTS Virtual Machine uses Wayland, largely due to entropy. Someone elsewhere wanted to know how to use it on the Live USB instance, and so I figured it out. I leave it as a live instance so I can test with mostly defaults. So far, so good.
MODERATOR'S NOTE - Everything from here to about #14 is from a Thread of the same title started more recently, Posts moved to here. Hope that does not confuse. Cheers, Wizard.

I've been using X11 for years, just wondering if anyone here is using Wayland and if so what are your experiences with Wayland?
Last edited by a moderator:
I have Wayland enabled in Ubuntu 20.04 and it seems to work OK with my Intel integrated graphics adapter.

No idea how well it works with dedicated graphics cards and uncertain what distros offer Wayland at this time.

Give it a try as if it doesn't work out or you don't like it you can always switch back to X11.

I am planning to try it but my current graphics card and drivers don't support it, I just bought a new one that does and I read that there are still things that may not be compatible with Wayland so that being the reason why I asked if anyone has any experience with Wayland.
I'll just give it go once I swap my my current graphics card with my new one. I already figured out which compositor I need and the backwards compatibility with X11 sounds nice just in case something doesn't work with Wayland.
My Ubuntu VM is generally configured to start with Wayland (to verify answers) and I only swap to X11 when the question calls for it. It stays up, stable and fully functional, in that use case.
I’m doggedly sticking with X11 for now.
I’m not going to be running Wayland until dwm is ported to run on it.
I’ve been hoping to be able to attempt a port myself, but I haven’t had time to even start looking at it yet!
Everything is here now

@KGIII take note the move.

Last edited:
I’m doggedly sticking with X11 for now.
I’m not going to be running Wayland until dwm is ported to run on it.
I’ve been hoping to be able to attempt a port myself, but I haven’t had time to even start looking at it yet!
i3 isn't either but sway is and it according to what I can find it's compatible with i3 so I'm willing to give it a try.
i3 isn't either but sway is and it according to what I can find it's compatible with i3 so I'm willing to give it a try.
For me, it's a blocker! No dwm, then no Wayland! Ha ha!

I suppose I could take a look at sway and try removing/disabling any unneeded features. I've also done some duckduck-go fu and discovered dwl - which might be exactly what I'm looking for.
But whatever happens, I'm probably not going to be switching wholesale to wayland for a while!

I found out I don't need an Nvidia proprietary graphics driver to run Wayland on Ubuntu 20.04.2 LTS.

Never could get Wayland to run on Ubuntu 20.04.2 when I was using an Nvidia proprietary graphics driver.

I reinstalled Ubuntu 20.04.2 and this time I decided to stay with the Nouveau open source graphics driver.

I'm now using Wayland on Ubuntu 20.04.2 and all is working well and no problems.

nelson@hp-pavilion:~$ echo $XDG_SESSION_TYPE

nelson@hp-pavilion:~$ env | grep -i wayland

nelson@hp-pavilion:~$ inxi -Fxz
System:    Kernel: 5.8.0-48-generic x86_64 bits: 64 compiler: N/A Desktop: Gnome 3.36.7 
           Distro: Ubuntu 20.04.2 LTS (Focal Fossa) 
Machine:   Type: Desktop System: HP-Pavilion product: GN556AA-ABA a6200n v: N/A serial: <filter> 
           Mobo: ECS model: Nettle2 v: 1.0 serial: <filter> BIOS: Phoenix v: 5.12 date: 06/11/2007 
CPU:       Topology: Dual Core model: AMD Athlon 64 X2 5600+ bits: 64 type: MCP arch: K8 rev.F+ 
           rev: 3 L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 svm bogomips: 11251 
           Speed: 1000 MHz min/max: 1000/2800 MHz Core speeds (MHz): 1: 1000 2: 1000 
Graphics:  Device-1: NVIDIA GT218 [GeForce 8400 GS Rev. 3] vendor: ASUSTeK driver: nouveau v: kernel 
           bus ID: 02:00.0 
           Display: wayland server: X.Org 1.20.9 driver: nouveau resolution: 1024x768~60Hz 
           OpenGL: renderer: NVA8 v: 3.3 Mesa 20.2.6 direct render: Yes 
Audio:     Device-1: NVIDIA MCP61 High Definition Audio vendor: Hewlett-Packard 
           driver: snd_hda_intel v: kernel bus ID: 00:05.0 
           Device-2: NVIDIA High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 02:00.1 
           Sound Server: ALSA v: k5.8.0-48-generic 
Network:   Device-1: NVIDIA MCP61 Ethernet vendor: Hewlett-Packard type: network bridge 
           driver: forcedeth v: kernel port: ec00 bus ID: 00:07.0 
           IF: enp0s7 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 76.69 GiB used: 8.79 GiB (11.5%) 
           ID-1: /dev/sda vendor: Hitachi model: HDS721680PLAT80 size: 76.69 GiB 
Partition: ID-1: / size: 74.49 GiB used: 8.79 GiB (11.8%) fs: ext4 dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 31.0 C mobo: N/A gpu: nouveau temp: 40 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 200 Uptime: 1h 21m Memory: 5.81 GiB used: 1.09 GiB (18.8%) Init: systemd 
           runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17 inxi: 3.0.38 
I just installed Wayland about an hour ago or so in Bullseye, and it works fine. I've been wanting to use it for a while now but after having read all those posts and articles claiming that "it's not ready yet", that "there are bugs here and there" and given the fact that Xorg just works, I simply didn't, till now. While in Xorg, I wanted to play a video in VLC and it didn't work; I got sound but no video, however, the video plays just fine in mvp. I launched VLC via terminal with the video as input and got this radeon: the kernel rejected CS see dmesg for more information a web search on that error led me to a post about some issues with radeon and Xorg, it was on BSD though https://forums.freebsd.org/threads/xorg-do-not-work-with-amd-again.70531/, but I started to wonder if that could be the case, so installed Wayland, switched to it, tried the video in VLC and it played this time without any issues, so maybe there's something weird going on that I'm not fully aware of. Then I came here, hit the search button, typed "wayland" because I wanted to know who amongst some of you guys already use Wayland and well, here I am, sharing my 1-hour experience ... plus a few minutes lol

Performance is faster and it seems as though it uses a bit less memory.
Responsiveness seems slightly better yeah, so far, but in my case it uses a bit more RAM, like 100mb more.
I'm using KDE Plasma by the way and had to install the pkg plasma-workspace-wayland logout and then login selecting the Wayland session in SDDM.
For some weirdness, I just checked.

I used the same user and the same virtual machine. The VM is a fully-updated Ubuntu 20.10 install, nothing added - bone stock. I used 'free -h' for all the commands, using it until I got three results in a row that were identical.

With Wayland: 694 MB of RAM in use.
With Xorg: 725 MB of RAM in use.

I tested Xorg first, logged out, and logged back in with Wayland enabled.
Well, I just got my first issue with Wayland(W) :(. I use megasync to download, upload and share files, it doesn't work in W, it launches then it crashes, it works, or at least it did last time I used it in Xorg(X). Launching megasync from the terminal gives this:
QSettings::value: Empty key passed
QSettings::value: Empty key passed
QSettings::value: Empty key passed
QSettings::value: Empty key passed
Not setting scale factors. Using predefined QT_SCREEN_SCALE_FACTORS= LVDS-1=1
A web search led me here https://github.com/meganz/MEGAsync/issues/275 though I bit old and not related to W, I tried some suggestions there to no avail. Like I said, it works in X, so I will switch back and check whether it does or not. I sent a report too.

Members online

Latest posts