Bluetooth usb problem

Peter0623

New Member
Credits
191
Good morning , Bluetooth is working in a roundabout sort of way .

Unable to get the headphones to automatically lock when switched on and the xfce does not detect any device on startup , at least using the graphical interface Blueman .

The only way at the moment for the Bluetooth icon to show is via the command line with :

sudo /etc/init.d/bluetooth.all start

Now the icon appears and even though the headset pairs , still the problem of it not being found in sound settings.
 


f33dm3bits

Gold Member
Gold Supporter
Credits
12,505
sudo /etc/init.d/bluetooth.all start

Now the icon appears and even though the headset pairs , still the problem of it not being found in sound settings.
You need to enable that service to start at boot, that way you won't have to do it manually every time your system. I'm not sure what init system Ubuntu 14.04 uses but you could try: service enable bluetooth.all .Now that you mention it you will also need to install the following module in order for pulseaudio to pickup your bluetooth device in the sounds settings. So install pulseaudio-module-bluetooth, then reboot just to be sure and then try again.
 
Last edited:

Peter0623

New Member
Credits
191
......pulseaudio-module-bluetooth already installed.

1 - sudo /etc/init.d/bluetooth.all start
2 - Blueman > audio sink
3 - Sound settings and now the headset is their.

How do you automatically enable all these commands at boot ?
 

f33dm3bits

Gold Member
Gold Supporter
Credits
12,505
......pulseaudio-module-bluetooth already installed.

How do you automatically enable all these commands at boot ?
I've been happy to help you but you have to got to do some yourself here too. You have chosen to keep running an old/outdated system and I have done my best to help you as much as I can. I'm not familiar with Upstart, why don't you start by using google but it looks like you would need to edit a file looking at an example. So you are probably looking for this file,/etc/init/bluetooth.all.conf or something like that and then in that file under "start on runlevel [2345]" add your current runlevel in the [ ]. It would be a lot easier to help you if you reinstalled your system with a current version of Ubuntu and you would be helping yourself as well because it would be easier to get things done.
 

Members online


Top