Cannot set fractional scale


New Member
Jan 5, 2024
Reaction score
In GNOME desktop, Display Settings, turn on Fractional Scaling and set Scale to 150%:


Click "Apply". The Scale is changed spontaneously from 150% to 200%.


No matter I click "Revert Setting" or "Keep changes", I have no way to set the screen scale to 150%.

What do I do to set the screen scale to 150%? If I can't do it in GUI desktop, you can also tell me command to do it. Thanks for your help.

This is my system:

This may not be your issue, so take it with a grain of salt, so to speak. I had a very similar issue in Mint. The "Unknown Display" at the top of that screen is what makes me think it may be related. I had to update the kernel in Mint to get mine to be recognized. Prior to that, I couldn't change my display settings either. It's worth a look anyway.
Certainly "Unknown Display" hints at a problem. Mine from the same Distro and version looks like this


... so it should at least have something like I have.

If you give us, in code tags, the outputs for the following it may assist

lspci | grep VGA



Fair question. :)

The OP could try it, as it is an option with the Ubuntu login screen.

Fractional scaling is possible on both Wayland and Xorg, though the process differs.

Mine is set to Xorg (X11), as is that of the OP, so I was trying to establish why his differs from mine, first, so we can see what he is lacking in terms of a standard install that should show his display in that screenshot.


Sorry for not mentioning my environment; I had thought this problem has nothing to do with environment.

I use Windows, for my poor memory to memorize Linux commands. (for example, I still can't remember how to ask find command to search for a particular file after 3 decades. Fortunately we have ChatGPT now). The Ubuntu environments I can access are either in WSL or in nodes of HPC, miles away from me, or in another continent. That's where Windows and Linux should be deployed, right?

For Ubuntu environment in WSL, I just realized it is much messy than I thought when it comes to fractional scaling: I don't hold my breath that WSL team can fix it in near future.

For remote Ubuntus, choose Wayland or Xorg at the login screen? Simply not an option, because 1) that's a shared server. 2) Wayland implementation like weston is not installed. I don't think changing fractional scaling needs sudo privilege on Linux, but rebooting needs. PS, I use TightVNC to connect to GNOME desktop of remote Ubuntus.

I encounter the same issue no matter I am in WSL or in GNOME of remote Ubuntu.

As for wizardfromoz's question, first, thank you for the reply. For WSL, I haven't yet install the graphics hardware, so lspci | grep VGA returns nothing. For remote Ubuntu machines, there is no gaming nVidia GPU installed, and AI GPUs are not allocated for GUI desktop. Although I agree off-loading fractional scaling computation to hardware is a good idea, I think it can also be implemented by software, just like OpenGL can be implemented by software, as long as one wishes.

As for treeshateorcs's comments, what I can say is that it sounds so much like US politicians criticising China for being autocratic, for being backward, for its govenment being corrupt, for its leader being a dictator, for their people living misarable lives. What funny words! The same words can be heard every now and then from Linux users critisizing Windows. How much do you know about X11? How much do you know about Windows? How much do you know about China? No system comes without a problem. For me, yes, I did try Wayland, but it is simply a cause of broken workflow, of commands not working, and of many strange errors, just like many problems in US when its people are still firmly believing their system is the best in the world.

From the screenshot of the Wizard, I can find out some reason for the problem. Users of Linux use 4K screen but they don't develop, while Linux developers are able to fix these issues but they don't use 4K screen.

Staff online