Can't figure out of this error

lomszz

Active Member
Joined
Nov 8, 2021
Messages
134
Reaction score
104
Credits
857
Hello i might have big problem, can't remove or install anything anymore. I was installing blender and there were error at end, while it's installed but can't do nothing else anymore, can't remove or purge anything or even install anymore.
Saying I'm missing dependency but tried install that deb package too but failed.

Pop os
Code:
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libgdal30 : Depends: libodbc2 (>= 2.3.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
lomszz@pop-os:~$ sudo apt remove --purge blender
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libgdal30 : Depends: libodbc2 (>= 2.3.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
lomszz@pop-os:~$ sudo apt --fix-broken-install
E: Command line option --fix-broken-install is not understood in combination with the other options
lomszz@pop-os:~$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libodbc2
Suggested packages:
  odbc-postgresql tdsodbc
The following NEW packages will be installed:
  libodbc2
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
68 not fully installed or removed.
Need to get 0 B/159 kB of archives.
After this operation, 471 kB of additional disk space will be used.
Do you want to continue? [Y/n]
(Reading database ... 265097 files and directories currently installed.)
Preparing to unpack .../libodbc2_2.3.9-5_amd64.deb ...
Unpacking libodbc2:amd64 (2.3.9-5) ...
dpkg: error processing archive /var/cache/apt/archives/libodbc2_2.3.9-5_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libodbc.so.2.0.0', which is also in package libodbc1:amd64 2.3.11
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libodbc2_2.3.9-5_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any ideas or only way to recovery?


edit: Never mind, i found solution and forced overwrite and fixed packages:D

First time something breaks on Pop, wrote this thread too fast, and need to write this step down so i remember next time.
 
Last edited:


lomszz wrote:
Never mind, i found solution and forced overwrite and fixed packages
Great to solve it yourself. It would be interesting to know though just what the commands were to "force overwrite" to get out of this problem you described if you'd be so kind.
 
It looked like the '.deb' was definitely corrupted if it couldn't unpack it.
 
Sure,
Code:
sudo dpkg -i --force-overwrite /var/cache/apt/archives/libodbc2_2.3.9-5_amd64.deb
Thanks for that which was previously unknown to me I guess because I've never had to use such a force-overwrite command. I have now found the overwrite option with the command:
Code:
dpkg --force-help
 
Thanks for that which was previously unknown to me I guess because I've never had to use such a force-overwrite command. I have now found the overwrite option with the command:
Code:
dpkg --force-help
Never had use myself either, we learn everyday something new :D
 

Members online


Latest posts

Top