• We did not send an email asking for donations - please read this post.

Curious issue with "b43" Broadcom on Dell Latitude D630...

MikeWalsh

Active Member
Joined
Aug 29, 2022
Messages
102
Reaction score
109
Credits
1,261
Hi, guys.

I'm noticing something odd with this D630.

It's got a total of 4 USB ports, but I really need 5. I DO have a PCMCIA card with an additional 4 ports......but this is where things get a bit weird.

The machine has Broadcom wireless, which uses the b43 driver.....OK? The machine has a PC Express card slot, and the card IS the correct type for the slot.

If I plug the PCMCIA card in the slot, then boot up, the card is recognised fine initially. However; as soon as the Broadcom wireless card connects.....the PCMCIA card promptly quits working!

Apparently, both run off the PCI bus. In almost 40 years of messing around with these boxes of black magic, I have never had this happen. Both components are recognised and supported by the kernel.....one starts working immediately, yet when the second one starts up, a minute or so later, it causes the first one to STOP working.

Anybody got any ideas? Remember; I run Puppy exclusively, and some of the 'standard' mainstream trouble-shooting utilities won't function here.....due to Pup's compile of Busybox running with a reduced Bash "instruction set". (Blame our devs, not me!)

I may have to end up buying a mini-PCI hub, though in all truth I only need a 2-into-1 USB adapter.....at least there's plenty of them about. I'm more curious than upset or annoyed.....just a bit miffed that a perfectly functional piece of equipment is apparently being disabled by summat else.


Mike. ;)
 


Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
3,174
Reaction score
2,062
Credits
23,622
My Dell Insperon also has the B 43 series Wi-Fi and using the kernel drivers it's never missed a beat, try uninstalling and re-installing the BCM43 kernel drivers
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
7,458
Reaction score
6,448
Credits
60,452
Wild speculation: Maybe an IRQ collision? I haven't had to deal with that in forever and a day, but the term (+Linux) may yield some fruitful results.
 

osprey

Active Member
Joined
Apr 15, 2022
Messages
287
Reaction score
193
Credits
2,631
MikeWalsh asked:
Anybody got any ideas?
Do the logs provide any clue as to why the card becomes null? Perhaps run "dmesg -w" and watch any changes.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Staff online

Members online


Top