Enable Ethernet/SSH using Buildroot [Solved]

Spearitch

Member
Credits
412

It appears the the "auto eth0" line is in the config file twice.
It is needed once.
I may suspect a lack of packages installed during the build. I didn't include ssh packages and I don't know which one are relevant in the case of Buildroot. You can find a list here and hope that it can be helpful.

 


Spearitch

Member
Credits
412

It appears that the "auto eth0" line is in the config file twice.
It is needed once.
Found it. First here is a list of packages I installed. The most important one iis openssh

a) In Developement tools For now I am sure that we will be needing: cvs, make, gperf, git,server support, pkg conf and libtool

b) in Interpreter languages and scripting: luajit, micropython, nodejs, perl, python3

c) in Networking applications: bridge-utils, ethtool, openssh,putty,ifupdown scripts

d) text editors and viewers: nano,optimize for size

e) Hardware Handler: fconfig, iostat,lmsensors, sensors, pwmconfig...

f)libraries

f.1) Compression and decompression: unrar, zip, lzip

f.2) Database: Mysql support

f.3) Filesystem: liconfig, libfuse, libconfuse

f.4) avascript: duktape, jQuery, jsmin, json-javascript

f.5) JsonXML: cJSON, json-c,json-glib, jsoncpp, libjson,libbson,libyaml,yaml-cpp

f.6) Text and terminal handling: ncurses programs,fmt

f.7) others: qlibc, libdaemon

cd ../etc/networks -->
nano interfaces

and follow my lead while modifying the file:


# Configure Loopback
auto lo
iface lo inet loopback

# Configure eth0 with static IP
auto eth0
iface eth0 inet static
#YourIP-Asdress but the last decimals have to be different from the ones included in your IP-Adress

address ...X...X...X...
#Your Broadcast address referred to Bcast in the MobaXterm window after you ifconfig -a
Bcast ...X...X...X...
#
network ...X...X...X...
#Your netmask that is generally fix
netmask
255.255.255.0

# Configure eth0 with dhcp IP
# auto eth0
# iface eth0 inet dhcp
```
Since we are using SSH to connect the board, it is useful to adjust some intern parameters and modify some files.

```
cd ../etc/ssh/
nano sshd_config
#Here Change the following line and remove the "#"
# Authentication:

#LoginGraceTime 2m
PermitRootLogin yes
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10

.
.
.
.
# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
PermitEmptyPasswords yes

PermitRootLogin yes

```
In the same directory:

```
nano ssh_config

# Host *
# ForwardAgent no
# ForwardX11 no
PasswordAuthentication no
 


Staff online

Members online


Top