Solved GRUB does not work in Kali

Solved issue


New Member
Feb 13, 2024
Reaction score
Here is my case - i have a dual boot system with Windows on my nvme and Kali on my other ssd. When i set up Kali and tried to boot it, it went straight to grub rescue. I then followed countless internet tutotials - booting from a live usb, reinstalling GRUB, trying to fix the System error 17 that was displayed after and I am still not able to boot into my Kali machine. Any help would be appreciated, because I am inexperienced and as of now - very desperate. Thank you in advance.

What is the exact error message you are getting at the grub rescue prompt?

I wrote an article that covers how to find out what is going on with Grub and how to rescue and or re-install Grub.

Is your machine a Dell by chance?
Reboot the system.
At the 3 second countdown before the Kali splash screen press ESC. The grub menu will come up.
The first entry will be highlighted. Press e to edit the entry.
Check the root (hd0,0) line should be highlighted. If it does show (hd0,0) this is wrong press e again to edit that line.
The grub edit>" prompt will come up, with "root (hd0,0)" already entered. Change it to read "root (hd0,2)" and press enter. This will take you back to the previous screen.
Press b. The system will boot normally.
because I am inexperienced a
Did you not read the Kali docs before you started?
Hi everyone! After 2 long days and countless attempts nothing worked. Turns out - the whole time i was trying to use GRUB Legacy and for some reason it just didn't work. Then i tried GRUB 2 and voilà - booted on the first attempt without even needing to update.
These were the steps i followed:
  • Boot from the live usb
  • sudo apt update; sudo apt install grub2
  • sudo mount /dev/sdc1 /mnt
  • sudo grub-install --root-directory=/mnt /dev/sdc
  • sudo update-grub (here i got an "/usr/sbin/grub-probe: error: failed to get canonical path of `overlay'" error mesage so i just didn't bother And there it is. For some reason grub legacy did not work well with my version of kali, i have no idea why. Anyway, thanks everyone.

Members online