Help installing Linux


New Member
Mar 30, 2023
Reaction score
I have a windows 11 laptop, Lenovo idea pad 110-15ACL to be specific, the machines now old and runs slowly so I decided to get Linux, I thought Ubuntu would be a good choice to start with, so I downloaded its iso file and created a bootable pen drive, when I try to boot into the pen drive, the pc just restarts into windows. I have secure boot enabled and have a UEFI bios, another issue after the first attempt of booting into the pen drive, it booted into windows, so I thought secure boot was a problem, so I tried going into the bios, to my Suprise the bios failed to load, it just restarts into windows when I try to load it. I've tried multiple fixes, but none seem to work, I know this is getting sort of bios oriented, but I just want to find out if I install Linux. But just as info I've tried, disabling fast boot, tried from the nova button, tried from the advanced startup, downloaded the new bios update, tried to flash the bios. None seem to work; is there just any way I could get any distro of Linux without going into bios.​

Welcome to the forums,
first disable windows quick start [fast boot] and secure boot usually found in the EUFI,
then follow instructions

Why not check out lenovo's own guide to installing linux on its own products:,
and, there are also lenovo linux forums where you can ask questions: .... ?

Basically the steps are, first, as Brickwizard mentioned:
  • disable fast booting;
  • disable secure booting;

  • set BIOS/UEFI to boot from usb;
  • copy an installation iso file to a usb;
  • verify that the iso file on the usb is valid;
  • start the computer and bring up the boot menu by pressing a key as it starts (e.g. F2 or F12 etc.);
  • select the usb from that menu and the installation should start.

There are few things that can get in the way of the above, but it's likely that the lenovo linux forums are most familiar with those things. The above steps are all it took for my own installation of linux on a lenovo thinkpad where the boot menu comes up with F12.

Members online