How to ping an ipv6 server from another server?

venn10

New Member
Joined
Mar 21, 2023
Messages
2
Reaction score
1
Credits
19
When I’ve ping one server’s ipv4 adress from another server with ping command it is pinging. But If i try to ping with ipv6 adress from one server to another it is not working. I’ve tried ping6 command too.
 


osprey

Well-Known Member
Joined
Apr 15, 2022
Messages
1,381
Reaction score
1,396
Credits
13,314
Do you mean something like the following is not working in your case?
Code:
[flip@flop ~]$ host google.com
google.com has address 142.250.204.14
google.com has IPv6 address 2404:6800:4006:811::200e
google.com mail is handled by 10 smtp.google.com.

[flip@flop ~]$ ping 2404:6800:4006:811::200e
PING 2404:6800:4006:811::200e(2404:6800:4006:811::200e) 56 data bytes
64 bytes from 2404:6800:4006:811::200e: icmp_seq=1 ttl=116 time=14.8 ms
64 bytes from 2404:6800:4006:811::200e: icmp_seq=2 ttl=116 time=14.0 ms
64 bytes from 2404:6800:4006:811::200e: icmp_seq=3 ttl=116 time=14.8 ms
^C
--- 2404:6800:4006:811::200e ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 14.010/14.535/14.823/0.372 ms
 
OP
V

venn10

New Member
Joined
Mar 21, 2023
Messages
2
Reaction score
1
Credits
19
Not exactly. I’ve connected to one vm in cmd. From there I’ve done ping test for another vm with ipv4 adress which is pinging. Where as if i try to ping test the same remote vm with ipv6 adress (through ping &ping6 commands) it is not responding.
 
D

Deleted member 108694

Guest
Try this
Code:
ping -6 google.com
and see if it is reachable

Check if you have IPv6 support on your system Use this command and observe its output:
Code:
ip -6 route

If you have a domain name and you want to get the replies from the IPv6, use the ping command like this:

Code:
ping -6 domain_name 
ping IPv6_address
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
9,770
Reaction score
8,631
Credits
43,749
This should be in either Linux Networking or one of the Server subcategories. Getting Started is for people trying to choose or install a Linux Distro.

If someone can advise me, I'll move it to the appropriate forum.

TIA

Chris Turner
wizardfromoz
 

sphen

Well-Known Member
Joined
Dec 12, 2022
Messages
871
Reaction score
753
Credits
10,429
Have you tried working out step by step from the host?

Try ping6 on localhost. Next, try it on the local IPv6 address (starts with fe80...). Next, try ping6 on its real LAN IPv6 address.

Next try ping6 on another host on the same LAN and visa versa.

Can you ping6 the router's IPv6 address on the LAN? Can you ping6 its public IPv6 address on the WAN?

Does your router offer a test capability? Can you ping6 out to the internet from there?

... you get the idea.
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
9,770
Reaction score
8,631
Credits
43,749
Thanks Your Lordship - moving it there.

Wizard
 

Staff online


Latest posts

Top