Installing a Network Manager sstp client VPN on Centos 8 Stream

kocek

New Member
Credits
32
Hello,
i am tryin to install a Network manager sstp client on CentOS 8 Stream. Doing a configure i get a message about missing libraries.
"......
checking for gmsgfmt... (cached) /usr/bin/msgfmt
checking for xgettext... (cached) /usr/bin/xgettext
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GLIB... yes
checking for SSTPC... yes
checking for GTK... yes
checking for LIBNMA... yes
checking for LIBSECRET... yes
checking for LIBNM_GTK... no
configure: error: Package requirements (libnm-gtk >= 1.2.0) were not met:

Package 'libnm-gtk', required by 'virtual:world', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix."


I have installed everything what was needed to this moment. I cant find this package for CentOS 8 on net.
Did someone installed the SSTP Manager on Centos or maybe there is another way to connect to sstp VPN?
 


kocek

New Member
Credits
32
Thank you jpnilson, i have found it earlier too, however it does not work even with terminal. Does anyone connect from CentOS 8 to sstp VPN?
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,444
Looking at that it needs a version greater than 1.2.0 of libnm-gtk, you could try finding the source and then compiling it.
However it looks like you're not the only one with the problem.
Or else you could try using this package instead, since it looks like it's for networkmanager as well.
Code:
Name         : plasma-nm-sstp
Version      : 5.18.5
Release      : 1.el8
Architecture : x86_64
Size         : 78 k
Source       : plasma-nm-5.18.5-1.el8.src.rpm
Repository   : epel
Summary      : SSTP support for plasma-nm
URL          : https://cgit.kde.org/plasma-nm.git
License      : LGPLv2+ and GPLv2+
Description  : SSTP support for plasma-nm.
 

kocek

New Member
Credits
32
I've add the plasma plugin, however i get the message "missing VPN plugin" in the command line also ncmli gives me a response."The VPN service 'sspt' was not installed".
I have installed the sstp-client for fedora28. I compiled also the original source and install but it does not work either.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top