Joined
Jan 8, 2021
Messages
3
Reaction score
0
Credits
46
Hi all, recently ive been using ngrok (a tunneling program) to expose my local ubuntu 20.04 minecraft server. For security purposes I decided to create a dedicated non-sudo user to run the minecraft and ngrok process. the problem though is when i try to launch ngrok i get this message:
cannot create user data directory: /home/minecraft_home/Minecraft_server_partition/snap/ngrok/29: Permission denied
the user 'minecraft_server' user owns its its user directory and all sub directories and ive tried changing the file permissions to allow any user, group, and other to read, write, and execute the directories in question.

i can run ngrok just fine without sudo privileges in my main user account. the difference between my main user profile and the minecraft profile is that my mian user profile was created with the gnome desktop user account controls, whereas the minecraft_server user was created using useradd.

its also interesting to note that when is ssh using my main gnome-created user account, i have full key board shortcuts, autofill (tab), my username and current dir are listed next to the prompt, and highlight colors are shown. when i ssh using the minecraft useradd account its just a plain prompt, no autofill, shortcuts, or color.

id really like to know why this happening both so i can understand linux better and so i can hopefully fix the issue

Thanks!!!
 


moehreag

New Member
Joined
Apr 20, 2021
Messages
1
Reaction score
0
Credits
9
I wonder you used the "useradd" command, try "adduser" instead since it is more friendly to set up and has more options and you will get keyboard shortcuts, autofill, your username, the current directory and colors. This may also solve the permission error if you put the directory you want as the "--home" option, for further information on the command I refer to its manpage at http://manpages.ubuntu.com/manpages/bionic/en/man8/adduser.8.html. I hope this solved your problem!
 
OP
R
Joined
Jan 8, 2021
Messages
3
Reaction score
0
Credits
46
I wonder you used the "useradd" command, try "adduser" instead since it is more friendly to set up and has more options and you will get keyboard shortcuts, autofill, your username, the current directory and colors. This may also solve the permission error if you put the directory you want as the "--home" option, for further information on the command I refer to its manpage at http://manpages.ubuntu.com/manpages/bionic/en/man8/adduser.8.html. I hope this solved your problem!
Hi! I know it was a long time ago but thank you for the response! I havent tried remaking the minecraft user, but you're right i did use useradd (which in guessing is the general linux command) instead of adduser (which im guessing is the ubuntu specific command?). Great to know theres a distinction! If i get a chance to try it with adduser ill update this thread.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top