[SOLVED] Audio problems on Pop! OS.

WaterExpensive

New Member
Credits
65
New to linux here, switched to Ubuntu then Mint and stuck on Pop! OS because it has all the video drivers pre installed and has some good performance. However, Sometimes the audio gets like 50% quieter and the only solution is to restart the laptop which is a bit annoying to do after a couple of times. Does anyone know what causes this or has a solution for my problem? It'll be much appreciated!
 


f33dm3bits

Gold Member
Gold Supporter
Credits
24,745
Have you played around with sound device settings(audio mixer) to see if any setting there made an improvement or difference, does the audio go quieter during certain moments when you are doing something else that requires audio or is it just random? Also try installing pavucontrol and playing around with the audio settings there since it has more settings than the default audio mixer installed in most distributions.
 

WaterExpensive

New Member
Credits
65
Have you played around with sound device settings(audio mixer) to see if any setting there made an improvement or difference?

Yeah i had actually, first was PulseEffect and then Pavucontrol, both of them raised the volume to an acceptable level but with an unworthy sacrifice of sound quality.

does the audio go quieter during certain moments when you are doing something else that requires audio or is it just random?

Well recently I've noticed a pattern where if i left the headphones for more than 10 minutes with no audio it'll switch to the low audio mode, I'm not sure though

Also try installing pavucontrol and playing around with the audio settings there since it has more settings than the default audio mixer installed in most distributions.

As I mentioned before, I did use pavucontrol but had to sacrifice audio quality which wasn't honestly good.

And thanks for the reply! thought this would be burred in the seas of forum question.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
24,745
Pulseaudio aren't the easiest, especially when you are trying to help solve someone else's problem. This sounds similar to your problem, have a a read and see if that does anything for your problem. Yeah some posts get buried but there are several members who try to react to the unanswered posts when they have time, there are members from all over the world here and many different time zones.
 

WaterExpensive

New Member
Credits
65
I'm not sure if I'm understanding this correctly but as I said before I don't use pulseaudio and pavucontrol since they sacrifice audio quality, and also just tried this but doesn't seem to be working since volume gets low again overtime
is there a chance that the pavucontrol is my only option here?
 

f33dm3bits

Gold Member
Gold Supporter
Credits
24,745
If you are running PopOS you have pulseaudio installed, open a terminal and share the output of the following.
Code:
dpkg --list | grep  pulseaudio
pavucontrol is a front-end to control pulseaudio: pavucontrol - PulseAudio Volume Control
 

WaterExpensive

New Member
Credits
65
Hey there, sorry for the late response and here's the output:

Code:
ii  gstreamer1.0-pulseaudio:amd64                    1.16.2-1ubuntu2                                      amd64        GStreamer plugin for PulseAudio
ii  pulseaudio                                       1:13.99.1-1ubuntu3.10                                amd64        PulseAudio sound server
ii  pulseaudio-module-bluetooth                      1:13.99.1-1ubuntu3.10                                amd64        Bluetooth module for PulseAudio sound server
ii  pulseaudio-utils                                 1:13.99.1-1ubuntu3.10                                amd64        Command line tools for the PulseAudio sound server
I hope this helps!
 

f33dm3bits

Gold Member
Gold Supporter
Credits
24,745
See, your are using pulseaudio, pavucontrol is just a front-end you can use to control pulseaudio which is a better one than the default audio mixer used in most distributions. Can you turn on some music, then open pavucontrol and then create a screenshot of the playback, output devices and configuration tabs?
 

WaterExpensive

New Member
Credits
65
Hey there, I actually seemed to have solved. the problem by restarting the PulseAudio servers when audio gets quiet, Kind of annoying but it does the trick for me atleast. Thank you so much for your replies it is much appreciated! I shall now put a solved tag on the thread? (Don't know if it has one)
 

f33dm3bits

Gold Member
Gold Supporter
Credits
24,745
You can just edit your original post and add solved to the title, but it sounds more like a workaround to me rather than a solution.
 

WaterExpensive

New Member
Credits
65
Well the workaround works well for me for now (I am a student so I just really needed a fast solution for now) I'll be sure to check for a script to restart the PulseAudio service automatically (if it even exists) but for now it works for me, thank you very much!
 

f33dm3bits

Gold Member
Gold Supporter
Credits
24,745
In your home directory create another directory and then you can add something to it, so something like this.
Code:
mkdir $HOME/bin
echo '#!/bin/bash' >> $HOME/bin/rpulse.sh
echo 'pulseaudio -k' >>  $HOME/bin/rpulse.sh
echo 'pulseaudio --start' >> $HOME/bin/rpulse.sh
chmod +x $HOME/bin/rpulse.sh
To restart pulse audio you can just then open a terminal and run: rpulse.sh (or you could create a shortcut for it and then just double click the shortcut for it to run. If you want it automatically done you'd have to find a way to check it and add that check to a script that it only restarts under certain conditionsand than createa cronjob for it.
 
Last edited by a moderator:

wizardfromoz

Administrator
Staff member
Gold Supporter
Credits
17,816
Good to see you got a workaround @WaterExpensive and welcome to linux.org :)

@f33dm3bits just a question on #12 - there are two references there to

rpusle.sh

Should they not be

rpulse.sh

?

Although the OP has worked through it, just for the benefit of future readers.

Cheers

Wiz
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Credits
17,816
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top