Timeshift & Similar Solutions - Safeguard & Recover Your Linux

Yes, it seems it did not take one last night
which browser?

When a notification comes in, you can either click on the "sherri the cat received new message....and it iwll open your email client with that message fron and centre......and/Or

you can just return to the page in question and click on Refresh icon
I closed Firefox. That got rid of the notifications. I had three tabs open, one in each thread.
It's creating a Snapshot now. No estimated time remaining. I'll post another screen shot
That's OK, it will do the trick, it's its first time.

Screenshot at finish please.
I hope I didn't sound rude when I said "That's what I'm talking about".

It's like time was out of sync or something with push notifications. I thought it was funny. Not sure that was communicated

And I was trying to keep up with 3 different threads. I wasn't sure where you were replying! Exactly what I thought it would be best to keep everything in one thread! :p
I've deleted the other Timeshift thread, so less confusion.

When the snapshot has completed, see if it resembles a little like I show at my #356 on previous page.

If so, you are safe to return to the thread what to do, and upgrade to 21.3 'Virginia'.

Brian or another will help if you need it.
Excellent. (double) Click the comments field beside it and enter something like

21.2 first snapshot

and press enter
When you use comments, it excludes that snapshot from any automatic culling protocols set in place, and that is particularly important for this one so that if anything goes wrong with the upgrade, you can restore.
Off on my road trip, see y'all in 2 hours.
@Sherri is a Cat , g'day

You said elsewhere, about Mint 21.3 'Virginia'

Instead of installing Linux from the desktop, I installed directly from the USB

Does that mean that you chose the Erase disk and install Linux option and replaced LM 21.2?

Why I ask is that you said elsewhere

A couple of questions...

Right now, the only thing I have to back up the system is a 64GB thumb drive. I'm not sure right now how big the system is right now. Do you think 64GB will be enough?

... and yes, that would be fine, but your Timeshift screenshot at #369 above, shows that the snapshot was stored to your /dev/sda2.

That means it was in a folder called /Timeshift created and stored on your Linux Mint 21.2 install.

If 21.2 has been deleted in favour of 21.3, that snapshot will have been lost.

If that is the case, you are best advised to take a manual snapshot (shows as O for On Demand, once taken) of 21.3 before you do any further changes with monitors, graphics, drivers and so on. And save it to that USB stick until you get another hard drive set up for storage.


First one, from Linux Lite's Manual is probably the better of the two.






Second question:

Can I upload the snapshot as a file to my Google Drive?

No. Timeshift snapshots need to be stored on a partition set up on a drive in Linux's EXT4 file format.
Second question said:
Can I upload the snapshot as a file to my Google Drive?

No. Timeshift snapshots need to be stored on a partition set up on a drive in Linux's EXT4 file format.
I have set them in various other filesystems, but they are not simply files that you can copy or sync to the cloud. The filesystem has to have the Linux' permissions and it should be a destination to which you can use rsync without loss of any metadata.

(Indeed, if you set up the timeshift snapshots in your system drive and it's on BTRFS, the process is instantaneous and super efficient in space. It's true that it only implements the good old "Restoration Point" a-la-Windows, but if that's what you need it's faster than light)

**** I'm going to stop here for a few minutes. I'm typing this on my tablet. Always a pain! My masters are bugging me for food and I want my Guatemala Antigua medium roast freshly ground beans Cafe ole-latte with espresso shots. I will post this unfinished. I'll come back using an actual keyboard to edit it with more details.

I rewrote everything. If you've read any of this, it would be best to start over.

A long time ago, in a galaxy far, far away...

  • I downloaded Linux Mint 21.2 and balenaEtcher.
  • I burned Linux Mint 21.2 to a 64GB USB 3.0 pen drive
  • I had NOT YET tried out Linux
  • One morning last week (after making my Guatemala Antigua medium roast freshly ground coffee been latte-cafe ole with espresso shots) I woke the ASUS out of sleep mode. AFTERI signed into my account, I saw strange lines on my monitor screen.
    • I've had issues on more than one monitor when the ribbons got damaged. This didn't look like that.
    • After all the issues with the Giant,the fact that the lines didn't look the same, and my prior experiences with intentional interference, I wouldn't be at all surprised if the problem isn't actually a “problem” at all. The Giant LITERALLY hijacked computers when they were pushing Win 10. I wouldn't put it past them to do this too.
  • I didn't know for sure if there was actually a problem with my monitor. I immediately turned off the PC.
  • The next thing I did was change settings in BIOS to ask me where to boot from. I loaded Linux 21.2 from the USB drive.
  • In the Live Linux desktop the lines were gone.
  • I explored Linux and chatted with people here online.
  • I decided to install Linux on the 2nd drive on my ASUS.
    • At this juncture... My memory is a little fuzzy about the order of things. I was p.o.'ed at the Giant and still concerned about my monitor
  • The next day I turned on my computer. I hadn't moved cables in the tower so I could install Linux on the other HDD.
  • Despite the changes I made in BIOS, I was not given the option to boot from the USB drive. Windows loaded.
  • I signed into my account
  • The picture was grainy this time.
  • I again worried about about my monitor. I shut down the ASUS.
    • My memory gets really fuzzy here.
  • The next time I started up the ASUS, I couldn’t see anything on the monitor at all. Totally black. And yes, the monitor was turned on. I got a message from the monitor that no signal was received from the PC.

This is where it gets confusing regarding which version of Linux I’m running , but my memory is more or less clear….

  • Luckily, I recently found this Lenovo. I got it out.
  • My monitor worked fine.
  • I booted into Live Linux 21.2 intending to install it alongside the Giant.
  • I clicked the option to do that.
  • I got a message that there was only 28 GB on the hard drive to divide between the Giant and Linux.
    • Before trying to install Linux, there was nearly 1 TB.
  • I got errors.
    • I couldn’t set up a password to install (Codex drivers?)
    • I stopped the installation
    • On the second attempt, I got the same message about Codex.
    • On the 3rd attempt I ignored the message about the (codex).
    • It got hung up on the time zone.
  • I looked at the release notes for 21.2
  • I was having issues mentioned in the notes.
  • I went back to the forum
  • I asked if it is possible to update the 21.2 release burned to the USB drive.
  • Communication got jumbled on the forum. I thought it was possible to update the burn on the USB drive.
  • I downloaded the updates. I thought it was being downloaded to the USB drive.
  • On my fourth attempt, I tried to install Linux with the updates
  • It got stuck on the time z
  • I stopped the installation.
  • On the 5th attempt to install, it again got hung up on the time zone.
  • I was told to wait, a full install could take a long time.
  • Something like an 1 ½ later, it was still hung up on the time zone.
  • I stopped the installation and shut down the laptop.
  • I intended to ask what I should do later on.
  • The next day, I couldn’t boot into Live Linux.
  • I couldn’t boot into Windows either. Even after trying to refresh, repair and reset to system settings, I could not boot into Windows or Linux.
  • I don’t know where the other laptops are. (Probably under junk in the back room that #4 wrecked before he left.)
  • I couldn’t download and burn 21.3 to a USB drive.
  • For reasons I won’t go into, I cannot borrow someones computer. I doubt the public library would allow me to install ballanaEtcher and then burn Linux 21.3 to a USB drive (forgot how to spell it!)
Why do my cats insist on laying on top of my mouse???

  • I thought I was f’d!
  • But then I remembered seeing the option to install Linux from the USB drive instead of booting into a live version, an OEM install.
  • I think files on the hard drive got corrupted after 5 attempts to install Linux. I prayed that the installation files didn’t get corrupted.
  • Thank God they didn’t! I was able to install 21.2
  • I wasn’t about to one more damn thing without advice! I did NOT download any update what so ever!
  • I came here to tell you what happened, what I suspected. I asked about updates to the current version and updating versions. That’s when I made the comparison to the process in Windows if your upgrading to the newest version. I.E. Get all updates to the current version BEFORE upgrading to the newest version.
  • Wizardfromoz and Condobloke advised me to take a Snapshot before upgrading to 21.3.
  • I did exactly that.
  • Immediately after every update since then, I’ve taken a new Snapshot.
  • Other than signing into my Firefox account, I haven’t done a single thing on this PC. Zip. Zilch. Nada. NOTHING.
  • Until I’m advised that it’s OKAY to move forward with ANYTHING AT ALL, I not downloading any app from any source. Period.

I know this is a lot. I just want to be thorough. Leave no question unanswered that might have any effect on something moving forward.

Thank you!
Last edited:

Members online