Solved Which ports need to be opened for Gerbera ?

Solved issue

Linux_User_77

New Member
Joined
Jul 17, 2023
Messages
3
Reaction score
0
Credits
25
Hi,

I am using "Suse_Tumbleweed" and Gerbera - Media-Server.
Which ports need to be opened for Gerbera server to be recognized.
I found this that I don't understand.
If I disable the firewall, the Gerbera server is detected.
Under Linux-Mint I had to release the following ports and then the server was recognized.

sudo ufw allow 1900/udp
sudo ufw allow 49152/tcp
sudo ufw allow 49152/udp

Under Suse this is not enough.


Thanks
 


i don't use gerbera or suse, but it looks like port 49152 may not be absolute. from here: https://manpages.opensuse.org/Tumbleweed/gerbera/gerbera.1.en.html
-p, --port Specify the server port that will be used for the web user interface, for serving media and for UPnP requests, minimum allowed value is 49152. If this option is omitted a default port will be chosen, however, in this case it is possible that the port will change upon server restart.
and here: https://docs.gerbera.io/en/stable/run.html?highlight=port#network-setup
You should also make sure that your firewall is not blocking port UDP port 1900 (required for SSDP) and UDP/TCP port of Gerbera. By default Gerbera will select a free port starting with 49152, however you can specify a port of your choice in the configuration file.
so it sounds like it might be helpful to specify a port in the config file and see if that works any better.
 
have you tried enabling or have you already enabled logging in the firewall to see what exactly is getting blocked?
 
The port opening settings were lost after each reboot.
Now I have set it correctly.
Now it works.

Thank you very much
 

Staff online


Top