Wifi Adapter, Bluetooth Adapter and Sound is not working after Nvidia Software Update

hkarakurt8743

New Member
Joined
Jan 21, 2022
Messages
5
Reaction score
0
Credits
62
I am using Ubuntu 20.04 (as second OS with Windows) and today when I switch to Ubuntu my second screen was not working. I used the solution from this thread External monitor not detected on Ubuntu 18.04 and it worked. After that something odd happened.

I am using TPlink Wifi Adapter and it is not working. When I type lsusb in terminal I can see the device (same thing for Bluetooth Stick) but I cannot connect to internet. In network options I cannot see Wifi option. USB port is working (I tried with External HDD) and everything works in Windows. I tried to connect my phone via USB and it worked but I could not share internet. I tried this USB ports have completely stopped working but it did not work. Also sound is not working and only output there is "Dummy".

I am completely stuck. I cannot connect to internet so I cannot update anything (ethernet is not an option in this case and sharing mobile internet did not work).

I have no idea to solve this problem. If anyone can give me a hint I would be so grateful.

Output of:

sudo dpkg -s linux-modules-extra-$(uname -r) | grep Status

dpkg-query: package 'linux-modules-extra-5.13.0-27-generic' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files.

Thank you in advance.
 


Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,388
Reaction score
1,606
Credits
17,944
Welcome to the forums
what is the Make/model of your machine,
please run inxi -n and post back the results
 
Last edited:

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,413
Reaction score
3,881
Credits
24,555
G'day hkarakurt, Welcome to Linux.org

Do you have Timeshift installed ?
 
OP
H

hkarakurt8743

New Member
Joined
Jan 21, 2022
Messages
5
Reaction score
0
Credits
62
Welcome to the forums
what is the Make/model of your machine,
please run inxi -n and post back the results
I am sorry but Command 'inxi' not found. It is not installed and I cannot install it because I do not have internet connection.
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,388
Reaction score
1,606
Credits
17,944
oh well.. what is your machine?
 
OP
H

hkarakurt8743

New Member
Joined
Jan 21, 2022
Messages
5
Reaction score
0
Credits
62
oh well.. what is your machine?
Output of lshw -short:

H/W path Device Class Description
======================================================
system System Product Name (SKU)
/0 bus ROG STRIX B460-F GAMING
/0/0 memory 64KiB BIOS
/0/44 memory 32GiB System Memory
/0/44/0 memory [empty]
/0/44/1 memory 16GiB DIMM DDR4 Synchronous 2933 MHz
/0/44/2 memory [empty]
/0/44/3 memory 16GiB DIMM DDR4 Synchronous 2933 MHz
/0/51 memory 512KiB L1 cache
/0/52 memory 2MiB L2 cache
/0/53 memory 16MiB L3 cache
/0/54 processor Intel(R) Core(TM) i7-10700F CPU @ 2.9
/0/100 bridge Intel Corporation
/0/100/1 bridge Xeon E3-1200 v5/E3-1500 v5/6th Gen Co
/0/100/1/0 display TU116 [GeForce GTX 1660 SUPER]
/0/100/1/0.1 multimedia TU116 High Definition Audio Controlle
/0/100/1/0.2 bus TU116 USB 3.1 Host Controller
/0/100/1/0.2/0 usb3 bus xHCI Host Controller
/0/100/1/0.2/1 usb4 bus xHCI Host Controller
/0/100/1/0.3 bus TU116 [GeForce GTX 1650 SUPER]
/0/100/14 bus Intel Corporation
/0/100/14/0 usb1 bus xHCI Host Controller
/0/100/14/0/5 generic 802.11n NIC
/0/100/14/0/6 input USB Receiver
/0/100/14/0/7 generic ATOLL-AB-IDP _SN:0DC2587C
/0/100/14/0/9 bus USB2.0 Hub
/0/100/14/0/9/4 communication Bluetooth Dongle (HCI mode)
/0/100/14/0/a input AURA LED Controller
/0/100/14/1 usb2 bus xHCI Host Controller
/0/100/15 generic Intel Corporation
/0/100/15.1 generic Intel Corporation
/0/100/16 communication Intel Corporation
/0/100/17 storage Intel Corporation
/0/100/1b bridge Intel Corporation
/0/100/1b/0 bus ASMedia Technology Inc.
/0/100/1b/0/0 usb5 bus xHCI Host Controller
/0/100/1b/0/1 usb6 bus xHCI Host Controller
/0/100/1c bridge Intel Corporation
/0/100/1d bridge Intel Corporation
/0/100/1f bridge Intel Corporation
/0/100/1f.2 memory Memory controller
/0/100/1f.3 multimedia Intel Corporation
/0/100/1f.4 bus Intel Corporation
/0/100/1f.6 eno1 network Ethernet Connection (12) I219-V
/0/1 system PnP device PNP0c02
/0/2 system PnP device PNP0c02
/0/3 system PnP device PNP0c02
/0/4 generic PnP device INT3f0d
/0/5 system PnP device PNP0c02
/0/6 system PnP device PNP0c02
/0/7 system PnP device PNP0c02
/0/8 system PnP device PNP0c02
/0/9 scsi0 storage
/0/9/0.0.0 /dev/sda disk 1TB CT1000MX500SSD4
/0/9/0.0.0/1 volume 99MiB Windows FAT volume
/0/9/0.0.0/2 /dev/sda2 volume 15MiB reserved partition
/0/9/0.0.0/3 /dev/sda3 volume 465GiB Windows NTFS volume
/0/9/0.0.0/4 /dev/sda4 volume 505MiB Windows NTFS volume
/0/9/0.0.0/5 /dev/sda5 volume 465GiB EXT4 volume
/1 power To Be Filled By O.E.M.
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,388
Reaction score
1,606
Credits
17,944
quite a new bit of kit..
ok lets try a basic approach,
re-boot, at the grub menu select ubuntu/linux advanced options
scroll down and select repair broken packages [not sure if it will work without intrnet but worth a try,
 
OP
H

hkarakurt8743

New Member
Joined
Jan 21, 2022
Messages
5
Reaction score
0
Credits
62
quite a new bit of kit..
ok lets try a basic approach,
re-boot, at the grub menu select ubuntu/linux advanced options
scroll down and select repair broken packages [not sure if it will work without intrnet but worth a try,
I actually tried it but it didn't work. Probably due to connection as you said.
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,388
Reaction score
1,606
Credits
17,944
Other thoughts on sound
occasionally, an update may mute the sound [check sound settings]
on laptops again, occasionally an update may hard block the sound if it's a laptop [try using the appropriate keys to unlock the sound…usual FN+another key]
network. do you know which chipset is in the network and wi-fi have [you may have to download new drivers to a pendrive using windows to enable you to re-install to linux]
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,388
Reaction score
1,606
Credits
17,944
last thought.. have you done a windows update in the last few days? not common but some times windows updates breaks linux


addendum this may help!
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
5,795
Reaction score
5,243
Credits
46,775
On the page you linked to, the one where you got your solution, there are 27 possible answers!

Could you link to the actual solution you used? Just below the answer, there's a 'share' link. Click that, copy that link, and post it here - please.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top