Can not start windows 10 after getting dualboot

Lanre

New Member
Joined
Mar 26, 2022
Messages
8
Reaction score
6
Credits
120
So... long story short. I'm an aspiring programmer, and I have ADD - the distractions of windows [all the programs, discords, websites, icons, games and such] are really detrimental to my learning process, so I have decided to install a Linux distro for the sole purpose of programming on there, while leaving windows for games and other useless time spending practices.

I have watched a couple videos, and decided to get Fedora Workstation [?], as it has been highly rated among the devs. I pulled out an old pendrive, flashed it, installed Fedora - everything was perfectly fine. Dual boot worked. I could use both Windows10 and Fedora, no problem. And that's when the garuda nation attacked.

While browsing useful videos and bits of software to install on my fresh Fedora I have stumbled upon a video about "really good looking" linux systems. Really modern ones. Now, looking back I am perfectly sure that very video has been uploaded by satan himself from the depths of his hellish domain. The video has included some short mentions about a couple of Plasma-based systems and such, and a larger one about a distro called "Garuda". It was built on arch [I think]. I have seen arch being praised a lot, as a good [albeit hard to switch to] system for developer work. It was flashy. It had those wobbly windows, transparency, gradient icons. It just looked pretty, and I wanted it.

So, tripple boot system. I already had a working dual-boot with Windows10 and Fedora, so I have decided to wipe one of the discs that held some old copy of Windows7 I had before, along with pictures and such [which I made a backup of] and roll with 3 systems, then decide which two to leave.

The problems started right at the installation phase. For 2 hours have I fought to install Garuda, it kept giving me error messages that didn't really make sense. "Can't edit partition". Why? "Because can't edit partition.". First thought? Let's google. After some digging around, reading up on other people having problems and the communitys... 'helpful' replies [some of their moderators replies bordered on agressive, and most of the posts looked like a typical "superclass" meme visage of a linux nerd, who thinks everyone, excluding himself, are idiots - sarcasm, sass, high-horse acting etc. you get what I mean], so I have decided it's not worth getting more white hair and I'll try some more myself. In the end, the problem [after disabling fast boot], was that I have ... named my computer system with a capital character. Seriously. "can not edit partition because can not edit partition" because of a bloody capital in the computers name. After changing it to all-lowercase, it ran - Garuda got installed on sdb. [I'll just say that apart from the system "flashyness" and nice looks, after already being antagonized by less than helpful error messages, and seeing how the "community" replied to other people asking questions, I spent less than 10 minutes using Garuda, then rebooted.]

That's where the real problem started. Somewhere along the way of trying literally EVERY option in the installer to get Garuda to work, I must have done something really stupid. I have no clue how, or what exactly was it but after the reboot, my Windows10 was no longer accessible. I have tried booting from bios, modifying [and reinstalling] grub2 on my Fedora [which I have access to], reading up on similar issues, but nothing so far helped. I can access my Windows10 files [including system partition] from linux, but I can't for the life of me boot into it.

I suspect I have broken the sda1 partition, which I THINK housed the bootloader for windows, or somesuch? I have tried several spells suggested by google to try and find out what's wrong. [attached files]

I'm in a pickle now. I may try to flash a pendrive with Windows10 and attempt a repair of sorts, if it is possible, but knowing how windows sees things it will probably result in W10 claiming all the PC as its property and removing my access to anything else [Fedora or others]. Also, not sure if that works, and I only have this one pendrive - if I flash it with Win10, and then it breaks both my access to linux AND to windows itself, I'm dotted. I won't be able to reinstall linux to continue.

So, my question is - do you guys have any ideas as to what could have happened and how could I fix it? My goal is a single grub, with primary Fedora system for coding, and a secondary W10 for gaming. Preferably without losing all my windows data [it's over 600gb of things I can't get back]

I can provide additional info, logs, or translation if needed.
 

Attachments

  • 1.png
    1.png
    214.9 KB · Views: 71
  • 2.png
    2.png
    15.8 KB · Views: 73
  • 3.png
    3.png
    96.3 KB · Views: 70
  • 4.png
    4.png
    7.8 KB · Views: 73


Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,656
Reaction score
1,758
Credits
19,882
Welcome to the forums

Ok .. let's see if *I have this right, you had Windows 7 and by your wording I would assume W10 on different drives you installed Linux on the W10 drive as a dual boot, then installed Garuda, on the W7 drive.. Assuming I have the right order of things, when you installed Garuda, did you choose the W7 drive? And did you choose to install alongside other systems?
As you had 2 versions of Windows ,the Windows boot manager was probably on the W7 drive, as it would have been the first one installed.
now, when you switch on, do you get the Linux boot grub manager? if so, is it showing Windows as a second option, and will it boot?
If not you will need to re-build the Windows boot manager, the re-start, boot in Fedora and update grub [rebuilding the windows manager will kill the current installation of the Linux grub

instructions to repair windows
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,656
Reaction score
1,758
Credits
19,882
OP
L

Lanre

New Member
Joined
Mar 26, 2022
Messages
8
Reaction score
6
Credits
120
Precisely, it might be the case! I had windows 7 HDD there that I took from my broken old laptop and added it to access files on it on my PC - it came much AFTER installing Windows 10. But when I was turning my PC on I had a choice between Windows10 and Windows7, so it may be the case that the boot manager was on the Windows7 one for whatever reason [maybe I reinstalled windows10 after adding Windows7, not sure] - should not be the case, but it's possible...

Sorry, I'm an aspie - my wording can be a bit jumbled. I'll make a list:

- I had an old laptop with windows 7 that didn't turn on [motherboard issue I think, it's old and dead]
- I have a PC that came with Windows 10. [sda system SSD + a 1TB sdc HDD for data]
- At some point I removed the HDD with Win7 from laptop and connected it to my PC to access my old files [this somehow became sdb if I'm not wrong]

Now:
- I have installed Fedora on a partition of my 1TB HDD [I shrunk it]
- Then I wanted to install Garuda on that partition, overwriting Fedora. It didn't work, so instead I just wiped the Win7 HDD [entire] and installed Garuda there
- That's when my windows 10 [and windows 7] became inaccessible.
- I tried getting it back on Garuda, but the workings of the system were unfamiliar and I didn't like the interface so instead I have reinstalled Fedora again on the 1TB data HDD partition [like it was before]

So now I have:
SSD with windows [inaccessible]
Old HDD [the win7 previously] with Garuda on it
The 1TB data HDD with my windows files on one partition [600gb] and Fedora on another of its partitions [250gb]


When I boot up my PC I can either access the Fedora grub [No windows there, just Fedora / Garuda] OR Garuda grub depending on which boot order do I choose in bios. Is it possible I have two grubs, on different physical drives?

Thank you, I will try the links you have provided and see if it helps - and thanks for the welcome!
 
Last edited:

captain-sensible

Well-Known Member
Joined
Jun 14, 2019
Messages
2,856
Reaction score
1,931
Credits
17,660
bit of a mix there and Widows7 a question mark- Windows 7 64 bit can boot uefi from what i've read but which version is installed ? A 64 bit CPU should be able to cope with a 32 bit version of Windows. but which version is it ? look in system blah blah of Windows to see that

Its possible I guess to have grub uefi mode with its files on an efi partition and on another disk maybe legacy grub MBR style on another disk. On programming by the way i've done Android ,python and php on the old Slackware . I switched first to Slackware current when php on Slackware 14.2 got to be a dinosaur, played with Arch derivatives then finally plumped for Arch vanilla, but generally i've found you don't need the most cutting edge to do programming .

If you go for Linux live OS on a usb , you will at least have have gParted and tools where you can take screenshots of disks that would allow to show in a simple way which disks have ab EFI partition and thus are uefi mode

then wirth a few commands to try out work out what is what . Now you can have Slackware 15 just released with persistence so packages can be installed to a limited capacity but they will still be there on re-boot using ALien Bob script. Also you can go via ventoy which allows quite a choice of booting OS straight from an iso file also with persistence via a 1gig or more file. See ventoy thread on this forum.

I don't know about devils but i bet if you asked your PC for its name i'm sure it would answer "Hal" (Stanley kubric ref)
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,656
Reaction score
1,758
Credits
19,882
the lyrics are a little different, but we are singing the same tune,
start by re-building the Windows boot sector
 
OP
L

Lanre

New Member
Joined
Mar 26, 2022
Messages
8
Reaction score
6
Credits
120
Alright, so.. Can you recommend something that I can flash a Windows recovery thingie onto my pendrive with?

I thought Balena Etcher, but it says Windows files need to be made bootable and it can not do it. For making one bootable on linux it recommends WoeUSB - the project seems closed tho, and it links to WoeUSB-ng.

I've got that but I'm having little problems writing my disc - the guide says to umount the pendrive [in my case it shows as /dev/sdd] and then run a command, but I can not do either - trying to umount the drive gives me a message that it is "not mounted", while trying the woeUsb command tells me "Access denied".

I have looked into the /media and /mnt, but those are empty.

1648337907663.png
 

captain-sensible

Well-Known Member
Joined
Jun 14, 2019
Messages
2,856
Reaction score
1,931
Credits
17,660
from a booted fedora try this command and see if it will say grub2-efi already installed :

Code:
# sudo dnf search grub2-efi
//then maybe we will know what grub fedora is using

i was thinking maybe a grub update might get the Windows 10 back

The other thing maybe is for you to reflect if you want everything back or willing to give any OS up - it just might make it easier. Windows10 is all bells and whistles at least thats what Microsoft says , so you want Windows7 for ? Chris has RHEL skills i'll call him in @wizardfromoz hes in Australia so might be time delay and its the weekend
 
OP
L

Lanre

New Member
Joined
Mar 26, 2022
Messages
8
Reaction score
6
Credits
120
I have tried updating and reinstalling grub [unless I messed up]

I only want Windows 10 back the way it was, and also my Fedora on dual boot [already in love with it] - windows 7 was never used, it was just there because it came with the laptop, and it's already gone because I used that disc to install Garuda [this one is getting removed]


The command output [and one I found on google, not sure if it's useful]:
1648375860736.png
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,656
Reaction score
1,758
Credits
19,882
How are you getting on re-building the win10 boot
 
OP
L

Lanre

New Member
Joined
Mar 26, 2022
Messages
8
Reaction score
6
Credits
120
Still stuck on trying to make the Windows10 iso I got bootable [3 posts up] - Thought I'd just simply use Balena Etcher like I did to get Fedora bootable, but it seems windows needs special treatment and I'm having difficulties using the other installer [WoeUSB]
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,656
Reaction score
1,758
Credits
19,882
Do you have an optical drive [DVD-Ror DVD-RW] on your machine, it may be easier to make DVD ISO [if you have a player]
 
OP
L

Lanre

New Member
Joined
Mar 26, 2022
Messages
8
Reaction score
6
Credits
120
Unfortunately no, I got rid of my DVD drive long ago [it broke and I have never really used it anymore either way]
 

captain-sensible

Well-Known Member
Joined
Jun 14, 2019
Messages
2,856
Reaction score
1,931
Credits
17,660
one thing you might try using your usb stick and fedora ( you said you can still bot it correct)

you can try ding a dd command on refind-flashdrive-0.12.0.img to your stick.

you download it by going to https://sourceforge.net/projects/refind/files/0.12.0/refind-flashdrive-0.12.0.zip
unzipping and then drag and drop that refind-flashdrive-0.12.0.img to your Desktop. From a terminal command change directory to Desktop then it will be along the lines of:

sudo dd if=refind-flashdrive-0.12.0.img of=/dev/sda

you can find what your usb stick i think (don't know RHEl at all) with the command :sudo fdisk -l


if you can do that; you shut down ,hit key to get choice of boot F9 in my case and boot from usb stick. I've tried it on Windows10 before and it could get Windows to boot. It might be able to get Windows10 up. if it doesn't work you can always use fedora to wipe ,reformat or anything else
 

captain-sensible

Well-Known Member
Joined
Jun 14, 2019
Messages
2,856
Reaction score
1,931
Credits
17,660
Still stuck on trying to make the Windows10 iso I got bootable [3 posts up] - Thought I'd just simply use Balena Etcher like I did to get Fedora bootable, but it seems windows needs special treatment and I'm having difficulties using the other installer [WoeUSB]
ventoy can boot Windows10 iso : https://www.ventoy.net/en/index.html
 
OP
L

Lanre

New Member
Joined
Mar 26, 2022
Messages
8
Reaction score
6
Credits
120
I'm going thru the Ventoy readme right now, I downloaded a zipped folder of files and unsure what to do with it now [has been years since I've used linux, not sure how do I "install" it for use]

Edit:
Ok, it's a sh script, think I have it worked out. Will try to make the bootable with it now
 
OP
L

Lanre

New Member
Joined
Mar 26, 2022
Messages
8
Reaction score
6
Credits
120
It's fixed, thanks so much guys!

The process, for anyone who might have the same problem:

- I've created a bootable Ventoy USB drive and copied the Windows10 iso to it [on Fedora]
- System reboot, booted up from the USB drive
- The windows 10 installer showed up, picked the "Repair system" in the lower right
- Tried an automatic repair - it failed.
- Opened the command line tool and tried Bootrec.exe /FixBoot - it failed [lack of permissions]
- Next, I have tried the Bootrec.exe /RebuildBcd command - success!
- After doing that I've tried doing an automatic repair from the GUI again - this time it worked.

The system has rebooted, repaired itself, rebooted again and I was presented with the Windows bootloader.

- After that I have logged into Windows, made a Fedora USB with their tool over again, then rebooted and installed it on SDB, wiping the Garuda linux into non existence. After a reboot I now get to choose if I want to start Fedora or the Windows 10 bootloader! :)
 

captain-sensible

Well-Known Member
Joined
Jun 14, 2019
Messages
2,856
Reaction score
1,931
Credits
17,660
next thing you might consider is to look for "timeshift" for fedora its like the Windows restore function . probably in the repo but ..https://src.fedoraproject.org/rpms/timeshift
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Staff online

Members online


Top