I accidentally messed up the networking service, network manager in ubuntu 22.04 for rtw_8822ce

NobinPegasus

Member
Joined
Feb 4, 2022
Messages
44
Reaction score
0
Credits
401
I accidentally messed up the networkin service, network manager. The driver rtw_8822ce is problematic in dual boot. So I somehow broke the thing. And now in the start up the wifi isn't getting enabled. Somehow I messed stuff that made my bootup very very long. So I undid everything erased and deleted all the networking and network-manager related file. So now what should I do? and previously my wifi automatically used to get disabled. and didn't get enabled until restart or sometimes restarting twice or thrice or even more. How to fix this?
 


The easiest way, if you are new to Linux would be to perform a fresh installation of Ubuntu.-:)
What operating system are you in a dual boot with?

With out the wifi connection working it could be challenging for you to install the network manager again.
You could configure it manually but you will have to know the ssid, essid, and the router or modems information. And/Or> edit the /etc/network/interfaces file.


**Try going into the Settings and click on the network menu and click the gear wheel of the desired network interface.
Next, click the IPv4 tab, then the manual configuration option. Then fill out your desired IP address, subnet mask, and default gateway. **
 
The easiest way, if you are new to Linux would be to perform a fresh installation of Ubuntu.-:)
What operating system are you in a dual boot with?

With out the wifi connection working it could be challenging for you to install the network manager again.
You could configure it manually but you will have to know the ssid, essid, and the router or modems information. And/Or> edit the /etc/network/interfaces file.


**Try going into the Settings and click on the network menu and click the gear wheel of the desired network interface.
Next, click the IPv4 tab, then the manual configuration option. Then fill out your desired IP address, subnet mask, and default gateway. **
With windows 11.
Fresh installation is a bit risky for me. As I've important files. And I've two SSDs. So I had two divide them properly during installation in the first time. I'm currently using the ethernet. So I will be able to do things. And my connection is pppoe.
So I'm not sure if static IP would work or not. What I'm suspecting is I'd changed some kernel codes. Where the timelimit was 5Minute. I changed it to 10s.
So on startup networking.service is not working I guess.
I'd also changed the /etc/network/interfaces
there was source /etc/network/interfaces.d/config ( I forgot the exact name) I removed that line too. And now.
I only have enp2s0, docker, lo but not wlan0 in ifconfig output.
 
The easiest way, if you are new to Linux would be to perform a fresh installation of Ubuntu.-:)
What operating system are you in a dual boot with?

With out the wifi connection working it could be challenging for you to install the network manager again.
You could configure it manually but you will have to know the ssid, essid, and the router or modems information. And/Or> edit the /etc/network/interfaces file.


**Try going into the Settings and click on the network menu and click the gear wheel of the desired network interface.
Next, click the IPv4 tab, then the manual configuration option. Then fill out your desired IP address, subnet mask, and default gateway. **
Also there's no option to add wireless connection
 
With windows 11.
Fresh installation is a bit risky for me. As I've important files. And I've two SSDs. So I had two divide them properly during installation in the first time. I'm currently using the ethernet. So I will be able to do things. And my connection is pppoe.
So I'm not sure if static IP would work or not. What I'm suspecting is I'd changed some kernel codes. Where the timelimit was 5Minute. I changed it to 10s.
So on startup networking.service is not working I guess.
I'd also changed the /etc/network/interfaces
there was source /etc/network/interfaces.d/config ( I forgot the exact name) I removed that line too. And now.
I only have enp2s0, docker, lo but not wlan0 in ifconfig output.
Editing configuration files and removing the arguments in them is not a good practice. Unless you are well versed in it doing so breaks the wireless internet connection daemon that communicates with the network manager.

I hope for your case you made a copy of the /etc/network/interfaces file before you edited it:-
 
Last edited:

Members online


Top