Interested to hear from anyone who has updated to LM21....either via the Update Manager, or via a Fresh Install?

DESPITE all the 'touches' of negativity in the posts above, LM21 is starting to turn the corner......slowly but surely it is becoming snappy and gives the feeling of reliability. The initial stumbles appear to have gone.

I must say that since I carried out the steps outlined in post#16 the "key" errors etc etc have disappeared...completely.

@charlie.corder ...consider installing it, Charlie. Nothing to lose. Make sure to install the updates frequently if you do install.
Upgrade instructions:

  • If you are running the BETA you don’t need to upgrade, use the Update Manager to apply available updates.
Will install.
I always have used update mgr. and install all updates regularly. Works for me.

So, for anyone following this ""story"".......the plot has deepened somewhat

Back on LM20.3 i had grub-customizer installed. I used it only to shift kernels up and down the list in order to boot from a particular kernel.
It was handy, very quick.
I installed it in LM21 as well. ....and THAT was enough to bring things unstuck.

grub-customizer introduces "complications" to the grub menu.....which are basically unnecessary, and can cause dramas down the track etc etc

I used to use it in 20.3 for the sole purpose of shifting a kernel up or down the list so that it would boot with the kernel I wanted it to.

However....I thought I will do the 'right thing'....and get rid of it....but I then read that uninstalling it does not do away with the customizations it has made.

So I uninstalled it...purged it (sudo apt purge grub-customizer etc etc)....and then went through the upgrade process again for LM21, "The upgrade overwrites files in /etc/ with default configuration files."........only to find that If I go to /etc/grub.d ...there is still a folder there named proxifiedScripts .....which supposedly belongs to grub customizer.


That one hits the nail on the head. I do wish I had read that prior to becoming entangled with grub customizer.

I was going to restore the clone I have of Una...LM20.3....but seeing that also has grub customizers grubby little paw prints all over looks like a fresh clean install in my immediate future.

Interesting (but also disheartening) to note some of the more obvious effects of uninstalling customizer and it bits and pieces....and still not really getting rid of the *(*( thing......when I shut down or reboot....the "coloured hieroglyphics" all over
the screen give me an "uh oh" feeling....not good.....they are harbingers of doom to come. SO...fresh install.

SO...fresh install took place.

Because I have two monitors, the second monitor is always a pain to set up properly.

Aside from that, the install itself is easy peasy....simple as can be.

Runs like the wind.

Just be sure to stay away from Grub-Customizer. You have been warned.





Just be sure to stay away from Grub-Customizer. You have been warned.

... and you were too, lol, in one of your Threads 5 years ago (I know, a long time ago)

For the Readers, if you use our search facility and type in




you will find me saying so in about 10 Threads from 2017 to as recently as July 2022 with Rado.

If I can get the empty beer bottles off the top of the retired Dell in the garage soon, I will use it to run a current version of GC and chronicle the headaches it causes in a Thread.

But Brian's comments above are a good start in that direction.


Just upgraded the Dell All-In-One that I have been running Linux Mint on to version 21 and it took hours but it ended up smooth sailing after I disabled the Timeshift Snapshot on the update manager since it was taking too long to calculate Disk Space and restarted the process.
LM21 running fine on my "Gaming Rig" Could never get it installed on an HP laptop. It had LM19 but even a new install would not work it may have been the USB even though it seems to check out. MX 21 installed from USB just fine and finally MX only now longer partitioned with a Win 8.1 OS.

Although the "Upgrade" to Mint 21 took about an hour because of the Timeshift. That took most of the time. Once it began the install it was actually about 20 minutes.
Today I installed Mint Cinnamon 21 in Virtualbox as seen here in Fullscreen mode...

Installed some software and all updates...changed Themes...Desktop picture...Boot sound...Shared Folder...Extention Pack etc. Seemed to run fine but as we know Mint runs a little slow as a VM...then the wheels fell off.

Every now and then when I Re-Start and Boot to the Desktop...I get a black screen with only the Desktop Icons but no Menu.

When a new version of Linux Mint comes out ie 18...19 or 20 there are some I always wait till say 20.1 or in this case 21.1 as that's when the bugs are fixed...should take my own advice...stupid me.
Good afternoon, {or Good aftermidnight in your case}
Last night I decided to start from beginning and register the total time it took from downloading the Linux Mint 21 Mate, burning the iso to a flash drive, and then installing it on my little Asus laptop.
I run LM 20.3 on my main rig, so that is where all the downloading and burning took place.
LM has a wonderful iso burning program installed otb. It's called USB ImageWriter and I have used it many times without any problem.
All I have to do is locate the iso file {which is in Downloads folder}, put it in "Write image" box, then find the Flash drive I want to burn it to, and then click on the Write button. Believe me, it does not get any easier than that.
Screenshot at 2022-09-04 12-11-07.png

When the Writer is finished working it will tell you.
Once that's done, it's off to the Asus.
Plug the Flash drive in, press start button, hold the esc button on the keyboard, change the boot order to the flash drive, sit back and watch it do its' thing, and then when the home screen comes up press the install button.
Total time for this whole operation . . . . . 47 minutes!!!!
It just doesn't get any better than that !!!

Happy installing to everyone.
Old Geezer
Tango Charlie
I went from 20.2 Cinnamon to 21 XFCE (fresh install, as I've heard that's the best way to do it) so I can improve the speed of my laptop, but it being an older laptop would explain why I don't see a massive improvement. While I'm not stubborn to change, I actually prefer Cinnamon instead. For starters, Cinnamon gives you more options for the theme, so I can't rice it the way that works best for me. Another annoyance is I can't delete programs from the start menu like I could in Cinnamon (I have to do so from the Software Manager instead). I don't know if this feature wasn't included, or if I'm not looking in the right spot, but I'd prefer having my programs appear as icons in the taskbar to make it look less cluttered. Because of those reasons (and others I'll eventually come across), I'm going to check out the MATE version instead. Yes, it takes up a little more CPU, but I'm willing to accept that trade-off. I'm also considering replacing my desktop environment with a window manager if I end up not liking MATE as well.

Update: I should make it clear that I'm only switching to another desktop environment so I can test out my new distro in a VM more smoothly. After I finally find a distro that works for me, I'm officially ditching Mint completely.
I have only ever used MATE with Linux Mint ever since I started using it, I tried XFCE once and I had the same experience with things missing from it that you would expect to be there and went back to using MATE again.
.Extention Pack etc.

I feel like I have been around and around in circles since LM21 "stable" was released.

to summarise, using the update manager was problematic....maybe it was just me?!....perhaps I was not holding my tongue in the right position?....who knows!?....I guess it really comes down to who cares !

I had problems with a usb stick in the middle of it all....I ended up running fsck on the nvme drive which lm21 was installed on and a multitude of errors presented themselves.Scrubbed that install....threw the usb stick across the room.

Fresh Install. Using a freshly burned iso on a fresh usb stick.

Install went flawlessly. Just like @charlie.corder's ....swift and to the point.

Then of course the various apps and stuff that I use every day has to be reinstalled from Software Manager. I had written a list.
A4 sheet of paper...fairly full. I did not observe line spacing so it maybe consumed half of the page.

Installing & setting up the various apps that I use took a long time....too long....enough to tick me off.

What am I talking about ?

brief, not all encompassing list
video downloader
catfish search
keyboard shortcuts

Set up twin monitors....panels, icons on panels, (not for the faint hearted) set up update manager/software sources,

Take care of little inconveniences like my sdd filling up from errant logs....kernlog and syslog in particular.......Also repair the fact that brave now wants me to "log in/forgotten gnome keyring password" each and every time I open it.

All good fun


Runs like the wind.
Totally stable. (Having said that, I still have a full Disc Image of LM20.3 on an external hard drive.....and a full Timeshift snapshot of same....just in case things go south. I do not really think they will....but ....I have been bitten....hence the double surety)

I can't think of anything else to inform about.

Every time I Boot to Mint 21 in Virtualbox I now get this...


Black screen...icons but no Panel or Menu and that's with 6GB of RAM and 256MB of video memory...I have to hit Reset which brings me to the Login screen...enter password and it Boots to Desktop and everything is there.

I have since deleted it as it's not worth worrying about because Mint 21.1 will be just fine...can't wait. These things happen with something new as I've experienced in the past.

I opened a Terminal in the black screen edition
but I couldn't close it because the top was missing...had to type Exit...must be a graphics problem too.
Last edited:
I just installed Linux mint 21 Xfce from a DVD and the install went without a hitch I then rebooted and updated my new install.

Then I decided to remove all of the default software stuff I'll never need or use which quite a bit I then rebooted and proceeded to the next step.

I've always been a fan of this website and use some of the suggested tweaks which are always benificial on my old clunkers.

Once I was finished with the tweaks from the above links I then installed some additional software and setup Firefox browser the way I like.

Okay a few hours later everything completed and here I am Linux Mint 21 Xfce on my 15 year old clunker.

I've never been a big fan of Linux Mint however I figured I give it a try and see what my experience is and so far so good.

With the exception of removing the unnecessary default software and installing some additional software my install is OOTB.

My 15 year old clunker.
linuxmint@HP-Compaq:~$ inxi -Fxz
  Kernel: 5.15.0-47-generic x86_64 bits: 64 compiler: gcc v: 11.2.0
    Desktop: Xfce 4.16.0 Distro: Linux Mint 21 Vanessa base: Ubuntu 22.04 jammy
  Type: Desktop System: Hewlett-Packard
    product: HP Compaq dc7800p Small Form Factor v: N/A
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 0AA8h serial: <superuser required>
    BIOS: Hewlett-Packard v: 786F1 v01.04 date: 07/18/2007
  Info: dual core model: Intel Core2 Duo E6550 bits: 64 type: MCP
    arch: Core Merom rev: B cache: L1: 128 KiB L2: 4 MiB
  Speed (MHz): avg: 1995 min/max: 1998/2333 cores: 1: 1995 2: 1995
    bogomips: 9310
  Flags: ht lm nx pae sse sse2 sse3 ssse3
  Device-1: Intel 82Q35 Express Integrated Graphics vendor: Hewlett-Packard
    driver: i915 v: kernel bus-ID: 00:02.0
  Display: x11 server: X.Org v: driver: X: loaded: intel
    unloaded: fbdev,modesetting,vesa gpu: i915 resolution: 1024x768~75Hz
  OpenGL: renderer: llvmpipe (LLVM 13.0.1 128 bits) v: 4.5 Mesa 22.0.5
    direct render: Yes
  Device-1: Intel 82801I HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  Sound Server-1: ALSA v: k5.15.0-47-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
  Device-1: Intel 82566DM-2 Gigabit Network vendor: Hewlett-Packard
    driver: e1000e v: kernel port: 1100 bus-ID: 00:19.0
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 37.26 GiB used: 7.95 GiB (21.3%)
  ID-1: /dev/sda vendor: Hitachi model: HTS541040G9SA00 size: 37.26 GiB
  ID-1: / size: 35.88 GiB used: 7.94 GiB (22.1%) fs: ext4 dev: /dev/sda3
  ID-2: /boot/efi size: 512 MiB used: 5.2 MiB (1.0%) fs: vfat
    dev: /dev/sda2
  ID-1: swap-1 type: file size: 1.7 GiB used: 0 KiB (0.0%) file: /swapfile
  System Temperatures: cpu: 47.0 C mobo: 43.0 C
  Fan Speeds (RPM): cpu: 1822 fan-2: 0 fan-3: 1240 fan-4: 1009
  Processes: 177 Uptime: 54m Memory: 5.72 GiB used: 1.15 GiB (20.2%)
  Init: systemd runlevel: 5 Compilers: gcc: 11.2.0 Packages: 1943 Shell: Bash
  v: 5.1.16 inxi: 3.3.13
I installed Mint Cinnamon 20.3 in Virtualbox and no black it's just a few bugs in 21 that I'm sure will be fixed in 21.1.