Black screen with blinking cursor / not booting after installation

FPSGaming

New Member
Joined
Aug 12, 2023
Messages
1
Reaction score
0
Credits
19
So recently I wanted to install Kali Linux to use alongside windows 10 as a dual boot system, I have used ubuntu in the pased so I uninstalled it before doing anything else even though the Grub boot loader for it is still present (also yes, I have tried removing the grub boot loader in admin win 10 cmd but it says something around the lines of "this can't be done on removeable media) the drive where I install kali on is my sub thumb drive because it's convenient for me, I flashed the kali linux iso onto an external hdd and installed kali linux onto my thumb drive, I also however installed the grub boot loader (when instructed) to the same storage device the kali linux OS would be installed on (which is the usb thumb drive) and I tried to boot it up after it was done installing and I was met with a black screen with a blinking cursor on the upper left corner of the screen, does anybody know what is happening? Help would be much appreciated.

 


sometimes that black screen with a blinking cursor means there was an issue with the gpu driver during the boot process. you could try switching to a different tty with Ctrl+Alt+F1 (or F2 - F6 if F1 doesn't work) and logging into a console to see if you could continue troubleshooting from there.
 
Kali is notorious for installation problems [many different ones] It doesn't contain all the non-free drivers other distributions do [it is based on a cut down version of Ubuntu] and is not suitable as an everyday drive for general computing [make sure you have read the full Kali documentation pages before you start.]
so what could be causing your problems
as @z7vl7abxc has mentioned, it may be a missing [or corrupt] GPU driver
you may have a corrupted download of the ISO [did you check the SHA sums]
you may have a bad burn/write to the USB [what did you use to make the bootable iso]

If you don't know what you're doing, Kali is not cool. And it can be a pain in the rear end.
If you want to Learn pen-testing then there are 8 or 9 other pen-testing distributions , several far easier to install, the one thing they have in common is, they all use the same "Tools"
 
That's your tty. Try ctl alt F1-F7 and see if you get a login. Then type startx. If it doesn't take you to the graphical screen cut your losses and reload.
 
You can log into it using a live boot usb but I doubt seriously you'll be able to fix it. It happened to me and it turns out that the wayland server and client were prevent the x server from starting.
 
If your able to get tty log in (use the ctl+alt on the right side and F1-F7). If you get this and can log in you can sudo su into root and try update-gub. You can also use systemctl to try and start or restart services such as xfce. lightdm, modem manager or xorg.
 

Members online

No members online now.

Top