Newbie wants to install Linux on laptop with UEFI secure boot

Going on with the exploration.

I could not make out a convenient guide to manual partitioning in GPT. Nevertheless, I did find useful information in quite a few and came to think that I would need 3 partitions: root, swap and home. Consequently, my first attempt was of no great success: there was no boot at all. I remember that I read somewhere :rolleyes: about the creation of an EFI boot partition. I just tried it out and I also thought it might make sense to install the boot loader there. Much to my delight, it worked out well. System is set up and runs smoothly. Timeshift is on and saves the snapshots in the home partition, so I guess I can safely proceed with this edifying journey.

Experimentally,

Luinxy
 


Hi again,

Now that I have been exploring for some time, I thought it might be of interest to know if everything is still all right. Therefore, I will leave some conclusive remarks here and move on to other threads if needed.
So far, so good. No serious problems. However, I did detect a warning in the terminal when running updates some time ago and started asking myself what it is about.

This is an example that I could later find in a log:

Code:
less /var/log/apt/term.log
Code:
Setting up nemo (4.2.3+tina) ...
Setting up nemo-dbg (4.2.3+tina) ...
Processing triggers for initramfs-tools (0.130ubuntu3.8) ...
update-initramfs: Generating /boot/initrd.img-4.15.0-58-generic
W: initramfs-tools configuration sets RESUME=UUID=975b89bd-218a-4d03-bd1c-504520f97a85
W: but no matching swap device is available.
Processing triggers for linux-image-4.15.0-60-generic (4.15.0-60.67) ...
/etc/kernel/postinst.d/dkms:
 * dkms: running auto installation service for kernel 4.15.0-60-generic
   ...done.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-4.15.0-60-generic
W: initramfs-tools configuration sets RESUME=UUID=975b89bd-218a-4d03-bd1c-504520f97a85
W: but no matching swap device is available.
/etc/kernel/postinst.d/zz-update-grub:
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'
Generating grub configuration file ...
I then searched for the warning:

W: but no matching swap device is available.

and found this discussion:

[FIX] no swap on fresh LM19 install with home directory encryption

I then looked at the output of:

Code:
ls /home/.ecryptfs
blkid
cat /etc/fstab
swapon --show
I saw that the UUID was different from the one in the log.

I checked the RESUME=UUID:

Code:
cat /etc/initramfs-tools/conf.d/resume
[FIX] no swap on fresh LM19 install with home directory encryption

Post by xenopeek » Wed Jul 25, 2018 10:29 am
There is an issue with home directory encryption that causes swap to be misconfigured during installation of Linux Mint 19, if you enabled home directory encryption during installation. This leaves you with swap that doesn't work.

To correct this run the following two commands after logging in to your new Linux Mint 19 installation:
sudo sed -i 's#/target##' /etc/crypttab
sudo sed -i '#^/swapfile#d' /etc/fstab

Finish with the following command:
sudo update-initramfs -u
...did not seem to fix it. I checked the RESUME=UUID again:

Code:
cat /etc/initramfs-tools/conf.d/resume
It was still the same. So, I did the following, using the correct swap UUID from the previous blkid/fstab output:

Code:
echo RESUME=UUID=0a5c80b4-ae6a-4475-944d-b160529b07be  | sudo tee /etc/initramfs-tools/conf.d/resume
Code:
cat resume
showed me that it had changed. Then I did:

Code:
sudo update-initramfs -c -k 'all'
reboot
So far everything is o.k. I am not really sure if it was necessary to do the fixing, but it seems at least that I did not break anything. Time will tell if that warning reappears. I will try to find out how to check if the swap is working correctly, but that is another story.

All in all, I really like the Mint experience and I am trying to get familiar with Bash.
 

Members online

No members online now.

Latest posts

Top