Problem with transferring media from Android to Xubuntu: LIBMTP error


New Member
Feb 10, 2021
Reaction score
Can anyone help me with this problem that is already making me almost give up on linux after a decade ??
I'm already sick of this problem that prevents me from transferring media from my cell phone to the computer and vice versa!
Whenever I try to move images, musics or videos it hangs in the transfer operation and then accuses this error of Libmtp.
I've tried all the solutions I found on the internet, more than two file managers, I've installed all the packages containing "MTP" on Synaptic and this keeps happening, with my two phones!
Please, someone to enlighten me with this headache?
Thank you guys

I'm using Xubuntu:
~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.5 LTS
Release: 18.04
Codename: bionic


  • Captura de tela_2021-02-10_17-03-30.png
    Captura de tela_2021-02-10_17-03-30.png
    13.8 KB · Views: 490

G'day @RenatoGFG and welcome to - what took you so long to join (10 years) :)?

Whenever I have a problem with my rig (and I have a number, as I run 66 Linux or so), I Google the error and place "solved" at the end, sometimes "linux" at the beginning, if the error could be mistaken for something else on Google.


error: libmtp could not get object handles solved

led me to some promising looking sites.

I have only checked one, which was part way down the page, a Youtube video looks like it is in Italian, rather than your Portuguese.

I viewed it without my sound on, and there were a number of steps, but I could follow the logic.

You have said

I've tried all the solutions I found on the internet,...

but have you watched that vid yet?

I'm from Australia so signing off for my Thursday shortly, but will check back tomorrow.


Chris Turner

BTW if you wish to try anything, run a Timeshift screenshot first, and if you have not come across Timeshift in the last 10 years, I am the one to speak to. :)

Members online