No sound

If there was no option to change the Profile, or no help, then try this:

Run alsamixer in a terminal, and show us a screenshot of that.

The ESC key will exit alsamixer.
 

Attachments

  • Screenshot at 2019-11-02 18-09-48.png
    Screenshot at 2019-11-02 18-09-48.png
    34.6 KB · Views: 454


I may be wrong but if that is the only sound card you have then I would think that should be switched to on.
That"s what I thought, too. But when I click to open the dropdown menu, I just hsve the same verbage.
 
I forgot to mention that when I was on there was an option to try by going into the hidden file directory and renaming a file, but I could never find the hidden file directory.
 
there was an option to try by going into the hidden file directory and renaming a file, but I could never find the hidden file directory.
We'll come back to this. It's very easy to do. And you need the lesson about hidden files and folders in Linux anyway. :D


But first, let's look at alsamixer again... that is, open it up again and try these steps (assuming that it still looks like your screenshot).

1. It starts on "Master" (see how it is highlighted with red letters). Use the up arrow on your keyboard to increase its value a little more. I can't read your fonts very well, but it looks like about 40% or so. You should probably hear that, but arrow up to about 60% - 80% anyway. Too loud would be welcome for a little while.

2. Now, use the right arrow to move over to the next item, Headphones. It is currently set to zero, but isn't muted. Arrow up on Headphones to about 60% - 80 % also.

3. Next, arrow right two spaces... it says "Front (something)", but it shows MM at the bottom. That is muted. So when you're on that column, hit the M key on your keyboard to unmute it. Arrow up as needed to a volume of about 60% - 80%.

4. On the next column to the right, another "Front (something".... arrow up as needed so it is also at the same volume as we've been doing, 60% - 80%

When all done, ESC out of alsamixer and reboot. When the system is back up, open a terminal and run this command below, and let us know if it makes any noise:
Code:
aplay /usr/share/sounds/alsa/Front_Center.wav
 
Last edited:
No joy here. 2 screenshots, 1 of the command line return and 2, just to show you the tray in the bottom right corner with the green arrow over the disc icon. Question, you are aware, aren't you that my sound preference screen showed the PC was using a "dummy stream?"
 
No joy here. 2 screenshots, 1 of the command line return and 2, just to show you the tray in the bottom right corner with the green arrow over the disc icon. Question, you are aware, aren't you that my sound preference screen showed the PC was using a "dummy stream?"
Crud, forgot the file attachments....grrrr
 

Attachments

  • Screenshot at 2019-11-02 19-37-46.png
    Screenshot at 2019-11-02 19-37-46.png
    23.7 KB · Views: 428
  • Screenshot at 2019-11-02 19-37-01.png
    Screenshot at 2019-11-02 19-37-01.png
    137 KB · Views: 442
Question, you are aware, aren't you that my sound preference screen showed the PC was using a "dummy stream?"
I suspect the "dummy output" (on the Output tab) is because your Hardware, the built-in audio card, is Disabled (Off).

So, one more time before we get to the hidden file trick. Run alsamixer again, just like before. This time, when it's running, hit F6 to select your card. It will probably show "default" highlighted, but if there is another selection, arrow down to it and hit Enter. Then, you may see other settings similar to those you just set. If so, repeat all the steps... if there is a MM showing, use the M key to unmute them, and set all volumes to a level that should make noise. Then ESC to exit alsamixer.

This time though, don't reboot. Just try to run the terminal command and see if you got sound. If not, then reboot and try the terminal command again.

If nothing again, we'll try the hidden file thing next.
 
Nada
 
Have you tried this in Terminal ?

sudo alsa force-reload

Then reboot.
 
I couldn't remember if I had or not ... here's the result
 

Attachments

  • Screenshot at 2019-11-02 20-14-32.png
    Screenshot at 2019-11-02 20-14-32.png
    39.3 KB · Views: 440
Not sure if this has already been suggested.......THIS PAGE is of interest
 
although, there was a "0" next to the Realtek sound card(?) option.
Well, not too worried about that. If it doesn't work, it doesn't work.

I am guessing that you tried the alsa reload that Brian just mentioned when following the steps in the other website. You had indicated that nothing worked in all those steps, except you missed the hidden file thing.

For the hidden file instruction, you don't need to see it.... just follow his instruction. Here it is again:
Code:
 mv ~/.config/pulse ~/.config/old_pulse
After running the command, reboot and test for sound. Just so you know, all this is doing is renaming a folder named "pulse" to "old_pulse". After renaming it, and rebooting, the sound system will generate a new folder... in hope of creating a clean configuration that works.

It's not the folder "pulse" that is hidden.... but it is in another folder that is hidden. A file or folder that starts with a period or dot (.) is usually hidden from view in your File Manager. So, it is the .config folder that is actually hidden, so of course you can't see anything inside it if you can't see it. In your File Manager, if you want to see hidden files and folders, hit CTRL-H to toggle them on or off. You will find there are quite a few in your home folder. You can view hidden files/folders with the command line too, but we'll save that for another day. o_O:D
 
ok, I'm getting ready to run that command line. Do you think it's wise for me to unhide the hidden files?
 
This sound test is probably the easiest... run the command below:
Code:
aplay /usr/share/sounds/alsa/Front_Center.wav

To save copy/paste effort, when you are in a terminal, you can use the up arrow to cycle through your previous commands. So you might have to up arrow 2 or 3 times or so, but you should get this sound test again pretty quickly. Another little command line trick for you! :cool::D
 
I did the reboot, still no sound. Previously, I was referring to your comment that I could unhide the hidden folders if I wanted to. I'm still a little nervous :eek: about doing something wrong and "blowing up" all this work we've put in on it. Albeit, I was speaking facetiously. :D
 
This sound test is probably the easiest... run the command below:
Code:
aplay /usr/share/sounds/alsa/Front_Center.wav

To save copy/paste effort, when you are in a terminal, you can use the up arrow to cycle through your previous commands. So you might have to up arrow 2 or 3 times or so, but you should get this sound test again pretty quickly. Another little command line trick for you! :cool::D
Thanks!
 

Members online


Latest posts

Top